Calibration for analytical chemistry

Calibration for analytical chemistry [R logo]

calplot | Plot calibration graphs
calpredict | Estimate measurement results including confidence intervals
din32645 | Calibration data from DIN 32645
pahCalibration | Calibration data for HPLC measurement of 4 PAH


Plot calibration graphs

Description

Produce graphics of calibration data, the fitted model as well as prediction and confidence intervals.

Usage

  calplot(x,y,intercept=FALSE,measurand="substance x",xunit="mg/L",yunit="Area",level=0.95)

Arguments

x | A vector of x values.
y | A vector of y values.
intercept | A boolean describing if the calibration curve is to be forced through zero.
measurand | The name of what is being measured as a character vector.
xunit | The unit of the given values on the x axis as a character vector.
yunit | The unit of the y axis as a character vector. Defaults to "Area".
level | The confidence level of the confidence and prediction bands. Defaults to 0.95.

Value

A linear model object for y ~ x. You will also get a plot of the calibration data, of your fitted model as well as lines showing the confidence limits and the prediction limits.

Author(s)

Johannes Ranke jranke@uni-bremen.de http://www.uft.uni-bremen.de/chemie/ranke

Examples

data(pahCalibration)
attach(pahCalibration)
## Not run: calplot(conc,phenanthrene,"Phenanthrene","mg/L")
detach(pahCalibration)
[Package Contents]


Estimate measurement results including confidence intervals

Description

This function generates estimates for x values from y values, including a confidence interval for the x values. The formulas in this function used for prediction of concentrations from (replicate) measurements are taken from the "Handbook of Chemometrics and Qualimetrics Part A" by D. L. Massart, Vandeginste, B. G. M., Buydens, L. M. C., De Jong, S., Lewi, P. J. and Smeyers-Verbeke, J, Elsevier, Amsterdam, 1997 and from the EURACHEM/CITAC report on "Quantifying uncertainty in analytical measurement", 2000, pp. 111f.

Usage

  calpredict(yobs,xi,yi,xunit="",level=0.95,intercept=FALSE,syobs=FALSE)

Arguments

yobs | A numeric vector containing the observed data.
xi | A vector of x values of the calibration.
yi | A vector of y values of the calibration.
xunit | The unit of the given values on the x axis as a character string.
level | The desired confidence level for the confidence interval of the estimates. Defaults to 0.95.
intercept | Logical value determining if an intercept is to be fitted or not. Default is FALSE.
syobs | If TRUE, a standard deviation for the given y values is calculated, and the resulting confidence interval will include this variability (not validated yet). If FALSE (default), this standard deviation is not included in the confidence interval. If a numeric value is given, it is used for the standard deviation of "real samples", in addition to the standard deviation of the y values in the calibration (also not validated yet).

Value

A list containing the estimate, its standard deviation and its confidence interval.

Author(s)

Johannes Ranke jranke@uni-bremen.de http://www.uft.uni-bremen.de/chemie/ranke

Examples

data(pahCalibration)
attach(pahCalibration)
y <- c(51.2,51.4,51.1,51.8)
estimate <- calpredict(y,conc,acenaphthene,xunit="mg/L")
[Package Contents]


Calibration data from DIN 32645

Description

Sample dataset to test the package.

Usage

data(pahCalibration)

Format

A dataframe containing 10 rows of x and y values.

Source

http://www.uft.uni-bremen.de/chemie

[Package Contents]


Calibration data for HPLC measurement of 4 PAH

Description

This dataset was produced during a course on trace analysis of organic contaminants. The data are far from perfect, but good enough to serve as an example.

Usage

data(pahCalibration)

Format

A dataframe containing the areas for the four polycyclic aromatic hydrocarbons (PAH) Acenaphthene, Phenanthrene, Anthracene and Pyrene. Each measurement of a standard solution makes up one row.

Source

http://www.uft.uni-bremen.de/chemie

[Package Contents]