aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules24
1 files changed, 0 insertions, 24 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index c82d270..0000000
--- a/debian/rules
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-# debian/rules file for the Debian/GNU Linux r-cran packages
-# Copyright 2004 by Dirk Eddelbuettel <edd@debian.org>
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/langcore.mk
-
-## We need the CRAN (upstream) name
-cranName := $(shell grep Package: DESCRIPTION | cut -f2 -d" ")
-## and we need to build a Debian Policy-conformant lower-case package name
-cranNameLC := $(shell echo $(cranName) | tr "[A-Z]" "[a-z]" | tr "." "-" )
-## which we can use to build the package directory
-package := r-cran-$(cranNameLC)
-## which we use for the to-be-installed-in directory
-debRlib := $(CURDIR)/debian/$(package)/usr/lib/R/site-library
-
-common-install-indep:: R_any_arch
-common-install-arch:: R_any_arch
-
-R_any_arch:
- dh_installdirs usr/lib/R/site-library
- R CMD INSTALL -l $(debRlib) --clean .
- rm -vf $(debRlib)/R.css $(debRlib)/$(cranNameLC)/COPYING

Contact - Imprint