Dose-response data evaluation

Dose-response data evaluation [R logo]

antifoul | Dose-Response data for TBT and Zink Pyrithione in IPC-81 cells
drdata | Get dose-response data
drfit | Fit dose-response models
drplot | Plot dose-response models


Dose-Response data for TBT and Zink Pyrithione in IPC-81 cells

Description

This data set shows the response of the rat leukaemic cell line IPC-81 to dilution series of tributyltin chloride (TBT) and Zink Pyrithione as retrieved from the "cytotox" database of the UFT Department of Bioorganic Chemistry on February 25, 2004

Usage

data(rivers)

Format

A dataframe containing 135 and 81 data points for concentrations and responses for TBT and Zink Pyrithione, respecitively. Additional data from the database is also present.

Source

http://www.uft.uni-bremen.de/chemie

[Package Contents]


Get dose-response data

Description

Get dose-response data from a remote mysql server

Usage

  drdata(substances, experimentator = "%", db = "cytotox", celltype = "IPC-81",
    whereClause = "1", ok = "'ok'")

Arguments

substances | A string or an array of strings with the substance names for which dose-response data is to be retrieved.
experimentator | The name of the experimentator whose data is to be used.
db | The database to be used. Currently only "cytotox" of the UFT Department of Bioorganic Chemistry is supported.
celltype | Currently, only data for IPC-81, C6, NB4, HeLa, Jurkat and U937 are supported.
whereClause | With this argument, additional conditions for the SQL query can be set, e.g. "where plate != 710". The default is 1 (in SQL syntax this means TRUE).
ok | With the default value "'ok'", only data that has been checked and set to "ok" in the database is retrieved. Another sensible argument would be "'ok','?'", in order to additionally retrieve data which has not yet been checked.

Details

The function is currently only used for retrieving data from the mysql database "cytotox" of the UFT Department of Bioorganic Chemistry. Additionally to the installation of the RODBC package, it is required to set up a ODBC data source with the name "cytotox", using an ODBC driver for mysql, probably myODBC. Then, under Unix, you can use iodbc or unixodbc for setting up the respective data source with data source name (DSN) "cytotox". For my setting using unixodbc, I am using the file ‘/etc/odbcinst.ini’ containing:
[MySQL] |  |
Description | = | MySQL driver for ODBC
Driver | = | /usr/local/lib/libmyodbc.so
Setup | = | /usr/lib/odbc/libodbcmyS.so

and the file ‘/etc/odbc.ini’ containing:
[cytotox] |  |
Description | = | Cytotoxicity database of the department of bioorganic chemistry, UFT Bremen
Driver | = | MySQL
Trace | = | Yes
TraceFile | = | /tmp/odbc.log
Database | = | cytotox
Server | = | eckehaat
Port | = | 3306
.

Value

data A data frame with a factor describing the dose levels, the numeric dose levels and a numeric column describing the response, as well as the entries for plate, experimentator, performed (date of test performance), celltype, unit (of the dose/concentration), and for the ok field in the database.

Author(s)

Johannes Ranke jranke@uni-bremen.de http://www.uft.uni-bremen.de/chemie/ranke

Examples

# Get cytotoxicity data for Tributyltin and zinc pyrithione, tested with IPC-81 cells
## Not run: data <- drdata(c("TBT","Zn Pyrithion"))
[Package Contents]


Fit dose-response models

Description

Fit dose-response relationships to dose-response data and calculate biometric results for (eco)toxicity evaluation

Usage

  drfit(data, startlogEC50 = NA, lognorm = TRUE, logis = FALSE,
    linearlogis = FALSE, b0 = 2, f0 = 0)

Arguments

data | A data frame as returned from drdata. The data frame has to contain at least a factor called "substance", a vector called "unit" containing the unit used for the dose, a column "response" with the response values of the test system normalized between 0 and 1 and a column "dose" with the numeric dose values. For later use of the drplot function, a factor called "dosefactor" also has to be present, containing the dose as a factor.
startlogEC50 | Especially for the linearlogis model, a suitable log10 of the EC50 has to be given by the user, since it is not correctly estimated for data showing hormesis with the default estimation method.
lognorm | A boolean defining if cumulative density curves of normal distributions are fitted to the data. Default ist TRUE.
logis | A boolean defining if cumulative densitiy curves of logistic distributions are fitted to the data. Default is FALSE.
linearlogis | A boolean defining if the linear-logistic function as defined by van Ewijk and Hoekstra 1993 is fitted to the data. Default is FALSE.
b0,f0 | If the linearlogistic model is fitted, b0 and f0 give the possibility to adapt the starting values for the parameters b and f.

Value

results A data frame containing at least one line for each substance. If the data did not show a mean response < 0.5 at the highest dose level, the modeltype is set to "none". Every successful fit is reported in one line. Parameters of the fitted curves are only reported if the fitted EC50 is not higher than the highest dose.

Author(s)

Johannes Ranke jranke@uni-bremen.de http://www.uft.uni-bremen.de/chemie/ranke

Examples

## Not run: data(antifoul)
## Not run: r <- drfit(antifoul)
## Not run: format(r,digits=2)
[Package Contents]


Plot dose-response models

Description

Produce graphics of dose-response data and dose-response relationships either combined or separately, for one or more substances.

Usage

  drplot(drresults, data, dtype, alpha, path, fileprefix, overlay,
    postscript, color, colors, fitcolors)

Arguments

drresults | A data frame as returned from drfit.
data | A data frame as returned from drdata. If data is to be plotted, the data frame has to contain at least a factor called "substance", a vector called "unit" containing the unit used for the dose, a column "response" with the response values of the test system normalized between 0 and 1, a column "dose" with the numeric dose values and a factor called "dosefactor" containing the dose as a factor. If plotting of the data is not required, data can be set to FALSE.
dtype | A string describing if the raw data should be plotted ("raw"), or an error bar should be constructed from the standard deviations of the responses at each dose level ("std", default value) or from the confidence intervals ("conf"). Of course, dtype only makes a difference, if a valid data object has been referenced.
alpha | The confidence level, defaulting to 0.95, only used if dtype "conf" has been chosen.
path | The path where graphic files should be put if any are produced. Defaults to "./" i.e. the current working directory of R.
fileprefix | A string which will form the beginning of each filename, if graphic files are created. Defaults to "drplot".
overlay | If TRUE, all output will be put into one graph, otherwise a separate graph will be created for each substance. In the latter case, on-screen display (postscript=FALSE) only works correctly for data plots. Dose-response models will all be put into the last graph in this case.
postscript | If TRUE, (a) postscript graph(s) will be created. Otherwise, graphics will be displayed with a screen graphics device.
color | If TRUE, a sensible selection of colors will be attempted. If false, everything will be drawn in black
colors | This is a vector of colors, defaulting to 1:8, used for plotting the data.
fitcolors | Here you can specify a palette for the colors of the dose-response fits. The default value is "default", which produces rainbow colors.

Value

results A data frame containing at least one line for each substance. If the data did not show a mean response < 0.5 at the highest dose level, the modeltype is set to "none". Every successful fit is reported in one line. Parameters of the fitted curves are only reported if the fitted EC50 is not higher than the highest dose.

Author(s)

Johannes Ranke jranke@uni-bremen.de http://www.uft.uni-bremen.de/chemie/ranke

Examples

## Not run: data(antifoul)
## Not run: r <- drfit(antifoul)
## Not run: format(r,digits=2)
[Package Contents]