aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorranke <ranke@d1b72e20-2ee0-0310-a1c4-ad5adbbefcdc>2005-08-08 15:23:33 +0000
committerranke <ranke@d1b72e20-2ee0-0310-a1c4-ad5adbbefcdc>2005-08-08 15:23:33 +0000
commit318518e17bace1b7dc0a4526af267edd88feb447 (patch)
treecf8ef03a2045c16924dd8da3f2d14f3acb034ce9 /debian/rules
parentc5f30593d42ecd9a21f799a4943709b1b73a1162 (diff)
Debianization.
git-svn-id: http://kriemhild.uft.uni-bremen.de/svn/drfit@35 d1b72e20-2ee0-0310-a1c4-ad5adbbefcdc
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..c82d270
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# debian/rules file for the Debian/GNU Linux r-cran packages
+# Copyright 2004 by Dirk Eddelbuettel <edd@debian.org>
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/langcore.mk
+
+## We need the CRAN (upstream) name
+cranName := $(shell grep Package: DESCRIPTION | cut -f2 -d" ")
+## and we need to build a Debian Policy-conformant lower-case package name
+cranNameLC := $(shell echo $(cranName) | tr "[A-Z]" "[a-z]" | tr "." "-" )
+## which we can use to build the package directory
+package := r-cran-$(cranNameLC)
+## which we use for the to-be-installed-in directory
+debRlib := $(CURDIR)/debian/$(package)/usr/lib/R/site-library
+
+common-install-indep:: R_any_arch
+common-install-arch:: R_any_arch
+
+R_any_arch:
+ dh_installdirs usr/lib/R/site-library
+ R CMD INSTALL -l $(debRlib) --clean .
+ rm -vf $(debRlib)/R.css $(debRlib)/$(cranNameLC)/COPYING

Contact - Imprint